Back to overview
Resolved
File server stability issues
Oct 16, 2022 at 10:30am UTC
Resolved
Oct 16, 2022 at 10:30am UTC
File server is experiencing intermittent hardware failures. Plex will be unavailable during file server downtime.
Affected services